Home Forums Etch shop papge layout stopped working on mobile

This topic contains 6 replies, has 2 voices, and was last updated by  Joshua 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #46571

    boavida.maria
    Participant

    Hello,

    i opened my website on mobile, and everything is out of the place – there is huge blank spaces between each item, why did this happened, and how can this be corrected?
    here is the link: http://www.serradura.pt/

    only the home page is correct.

    thank you

    #46572

    Joshua
    Keymaster

    I see the issue. It looks like your H2 and H3 line-heights are set very high (1816 and 276 respectively). This would make the h2 tag 1816 times it’s original height.

    Can you confirm these are what’s set in theme options? If so, adjusting those to normal numbers (usually around 1-3) will resolve the issue. Otherwise post back here and let me know if that doesn’t work as something else may be conflicting with Kirki.

    #46576

    boavida.maria
    Participant

    hello,

    the line-heights of H2 and H3 respectively are set to 3 and 2.. (it doesn’t say the unit)
    is there another place this can have changed, that i should look?
    i went to: appearance – customize – typography

    thank you,
    maria

    #46577

    boavida.maria
    Participant

    there must be some conflict:
    now i erased the values of the line-heiht, and it was ok, but the title gets no space between the next image (for example shop)
    if i set to “1” then there is again a huge huge space.

    what can i do?

    #46578

    Joshua
    Keymaster

    Sorry you’re still having this issue. I believe I’ve found the cause. Looks like it may come from an update within Kirki Toolkit causing a miscalculation for mobile line heights within the theme.

    You should be able to add the line-height back in to your settings and remove or comment out all the line-height lines from etch/lib/framework/options/body/typography.php. These should be lines 8, 16, 24, 32, 40, and 48.

    To comment out a line in this file, you’ll need to FTP into your server and when you open this file add two forward slashes before each of those lines. For example, line 8 would be:

    //'line-height' => $value['line-height'] * 1.19,

    Please let me know if this resolves your issue and we’ll release a fix ASAP.

    #46579

    boavida.maria
    Participant

    Hello,

    YES! you’re right – it’s solved!
    thank you very much.

    maria

    #46580

    Joshua
    Keymaster

    Thanks for reporting back, Maria!

    We’ll get this updated and uploaded to ThemeForest shortly.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.