Home Forums Fusion Scattered Portfolio Grid & Additional Items going missing

This topic contains 14 replies, has 2 voices, and was last updated by  queenlo 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #47407

    queenlo
    Participant

    Hi Josh,

    I’m having trouble with the portfolio grid as it’s shown on the home page in the Freelancer demo. I LOVE the scattered portfolio grid, but the Additional Info sections are giving me trouble. Sometimes I add text and then it shows up and if I add another item, they both disappear and I have to start over, and then they’re still not very stable. I’m worried about their reliability over time as I make changes. Also, I’m not sure how the grid works — if I add too much text to Position 0, instead of pushing down the image in Position 2 below the Position 0 block, it wraps underneath the photo.

    I’m having that same issue with the Additional Info sections in the Content Carousel further down the page, which I am using for testimonials. Sometimes editing one of those text items makes everything disappear. This will be a nightmare for updates if I can’t stabilize those Item sections.

    Here’s my link

    http://0ce.8d1.myftpupload.com/home/

    Thanks,

    Laura

    #47408

    queenlo
    Participant

    Sorry, another issue I’m having with that Scattered Grid — no matter how I update the settings, the Edit mode in the backend shows the original Portfolio items that were included in the demo, even if I turn them off to Draft to try to display a different Portfolio item that I actually want to show. Am I doing something wrong? It makes it hard to edit the order and how everything looks if I want to add new portfolio items or change the order of things.

    Thanks,

    Laura

    #47411

    Joshua
    Keymaster

    Hi Laura, we’ll separate this into 2 parts:

    1. I can confirm that there is an issue occasionally with the WYSIWYG editor inside repeater fields. Elementor claimed to have fixed it in August ( https://github.com/pojome/elementor/issues/2220 ), but after testing it seems like it still sometimes occurs.

    This issue does not appear to happen when using a regular textarea, so this is one fix we can offer in the meantime. Unfortunately, that does mean we’ll lose the formatting buttons and image inserts, but HTML can still be copied from another WYSIWYG to here. We can revert this back after Elementor fixes the issue.

    2. As for the same portfolio items appearing, this sounds like it may be a caching issue.
    – Can you try refreshing your browser cache and turning off all caching?
    – What host are you currently using?
    – Does other content reflect as updated on the page?
    – If you duplicate this page and edit it, does it work?

    #47416

    queenlo
    Participant

    Hi Josh,

    1. Oh boy. I’m not sure I understand what the fix is then — how do I even use the portfolio grids and the carousels if they keep breaking? I’m not sure I understand what the workaround is that you’re suggesting — using a text + image area alone for the content carousel doesn’t give me the slider functionality I was looking for, and the portfolio grid sounds like it’s actually not useable with text at all?

    Can you clarify please?

    2. For the portfolio items… I have emptied and refreshed my browser cache several times, and yes, the other content on the page shows up as it’s supposed to. It’s just the portfolio pieces. The site host is Godaddy.

    Thanks…

    #47417

    Joshua
    Keymaster

    1. I think you might be misunderstanding quite a bit. This only relates to the repeatable fields, not to the actual portfolio or post items in grids/carousels.

    We’re switching the “Additional Items” repeatable fields to use a textarea instead of the current wysiwyg area in the next update. This still allows full use of text and HTML and your content will remain unharmed. The only difference is that you don’t have easy access to WordPress’s formatting buttons (insert image, bold text, etc) because this feature is causing disappearing content currently. That doesn’t mean those elements aren’t usable here, just that the toolbar will not show up. This is not ideal, but we really can’t do anything about this until Elementor updates.

    If you’re not comfortable with HTML and need to use images or other formatted text here, I recommend you open a separate tab with a WYSIWYG editor in your WordPress dashboard and copy/paste this content into the item content field for now.

    2. Please try disabling all non-theme related plugins and test again. If that doesn’t work, please privately post a link with your site login credentials and I’ll take a look.

    • This reply was modified 2 weeks, 1 day ago by  Joshua.
    #47419

    queenlo
    Participant

    Ah — ok, I understand better on number 1 now, thanks… but when will that next update be released? I’m trying to launch a site by next week and I’m feeling a little stuck.

    #47420

    Joshua
    Keymaster

    Should be out by tomorrow morning. Just need to test this more and add a couple other changes before pushing.

    #47421

    queenlo
    Participant

    Wonderful!! THank you!

    #47423

    queenlo
    Participant
    This reply has been marked as private.
    #47424

    queenlo
    Participant
    This reply has been marked as private.
    #47426

    Joshua
    Keymaster

    The color widget issue is related to a recent WordPress update. This was resolved in Fusion 1.3.23 (you can update to this version to resolve).

    Looking at your Elementor and front-end, the portfolio grid on the homepage seems to be displayed correctly. Currently it’s pulling in the only 3 portfolio items that aren’t set to “Draft.” Changing the images or status of these portfolio posts also reflects correctly in Elementor and the front-end.

    Is there a different issue here that I’m not seeing?

    #47430

    queenlo
    Participant

    OK, I got that Fusion update and it did fix the Portfolio Details — thank you!

    Any update on that Additional Items fix?

    And last question from first post in thread above — can the photos in the Scattered grid get pushed down depending on how much text is in Position 0 for example? Right now, the text in Position 0 is disappearing under the photo in Position 2… Is there some CSS I can add to make this happen?

    Thank you!

    #47431

    queenlo
    Participant

    Oops — just realized the Additional Items does now seem to be different, and I was able to copy & paste in the HTML for the styling as you suggested before. Thanks for that! I’ll try it in the Content Carousel too and make sure it’s stable.

    So, just that question about adding some CSS to control the text / photo relationship between positions.

    Thanks a lot Joshua!

    #47435

    Joshua
    Keymaster

    So the grid style you’re using currently has set sizes for each position to create its effect. If you wanted to make just the additional items height variable, then you could try adding this to your Custom CSS:

    .grid-item-insert {
      height: auto !important;
    }
    #47444

    queenlo
    Participant

    It works! THANK YOU!!!

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.