Home Forums QuickStep Quickstep Top Nav not working in Chrome 61

This topic contains 8 replies, has 4 voices, and was last updated by  Joshua 5 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #46909

    mycloc
    Participant

    Hello,

    It looks like the Top navigation bar (with the single-page scrolling) does not work in the latest version of Google Chrome (on Mac, PC and Android). It works in all previous version of Chrome. i’ve tried this in my own install of the theme, as well as your demo sites.

    Mike

    #46912

    Joshua
    Keymaster

    Hi Mike,

    I just checked our demo and it looks to be working on the latest version of Chrome.

    Could you try from a different computer? Maybe a different account as well since you may have a plugin running that’s causing the issue?

    You can also provide your site as well to help us determine the issue if the above is not the case.

    #46958

    mycloc
    Participant

    Hi Joshua,

    I’ve also tried this on virtual machines on Crossbrowsertesting.com on OSX, Windows 10 and Android platforms. In all cases, the top navigation does not scroll the page on Chrome 61, but it does work on Chrome 60 and below.

    The site I’m working on is fiorellascucina.com — but I also find the same issue with your demo at quickstep.themeluxe.com

    #46959

    Joshua
    Keymaster

    Thanks for reporting back with all that info. I believe I see the issue now. Unfortunately Chrome has updated this which will break a lot of sites and plugins. In particular, the scrollTo plugin packaged with Quickstep needs to be updated and luckily was updated a few weeks ago.

    1. In your themes folder quickstep/js/jquery.scrollTo.js entirely replace the content with this – https://raw.githubusercontent.com/flesler/jquery.scrollTo/master/jquery.scrollTo.js

    2. In quicksetp/js/customjs.php you’ll need to find and replace every occurence of:

    jQuery.scrollTo.window().queue([]).stop();

    With this:

    jQuery(window).clearQueue();

    That should be all that’s needed to get it working. Sorry about the delay in getting this to you and please post back if you have any questions.

    #46966

    mycloc
    Participant

    Thanks, Joshua, for the quick response; this fix seems to have addressed the problem!

    Mike

    #47046

    georgia.lewis
    Participant

    Hi Joshua,

    I am having the same issue with my site emergeconference.co.uk. It won’t scroll down to the pages when you click on the top navigation on Chrome, but works on all other browsers.

    What do I need to do to fix this issue?

    Thanks,
    Georgia

    #47051

    Joshua
    Keymaster

    Hi Georgia,

    The fix is mentioned earlier in this thread. Have you tried this yet? http://themeluxe.com/support/topic/quickstep-top-nav-not-working-in-chrome-61/#post-46959

    #47097

    ethene
    Participant

    Dear Joshua,

    I have tried the 2 steps you mentioned here but it still does not solve the problem in chrome. It worked on IE though…

    My site is at http://www.skyy.com.sg

    Any other solutions to this?

    Thanks a million!

    • This reply was modified 4 days, 21 hours ago by  ethene.
    • This reply was modified 4 days, 21 hours ago by  ethene.
    #47100

    Joshua
    Keymaster

    Hi @ethene – your scrolling appears to be working in the latest version of Chrome. You may need to refresh your browser cache.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.