Home Forums QuickStep On-site Linking

Tagged: 

This topic contains 23 replies, has 2 voices, and was last updated by  Joshua 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
    Posts
  • #47864

    Totally_Red18
    Participant

    Hi
    I a really happy with the format of my Home page (totallyredms.co.uk) but am having some problems with linking. I am trying to achieve two things, please could you let me know if these are possible and how?

    1, Linking between sections on the Home page i.e. click a contact us button and the page scrolling to the section, I tried adding the slider= urls but it scrolls to the bottom of the page and attempts to create a duplicate of the requested section?

    2, Linking to additional pages on site. I offer a range of services that I briefly introduce on the homepage but would like to link a find out more button to a new dedicated page, is this possible? or is this not possible in this theme?

    All advice much appreciated!
    Many thanks

    TR

    #47865

    Joshua
    Keymaster

    Sure, no problem.

    1. If you want to link to somewhere on the homepage the URL should be your homepage url with the “slide” (not “slider”) attribute added to the end of the URL. For example:

    http://yourdomain.com?slide=contact

    2. If you add the ‘separate’ class to any link (or available as an option for shortcodes) it will not load via AJAX in the homepage and open in a new page.

    [link separate="true" link="/post-name"] Change the current page without AJAX[/link]

    #47871

    Totally_Red18
    Participant

    Hi Josh,
    Thank you so much for the above response. I will try this out ASAP, I am having a slight issue preventing this though that I am hoping you might be able to assist me with? when i try to access https://totallyredms.co.uk/wp-admin/ I was getting a blank screen (I have just tried again and am now getting “Warning: Cannot modify header information – headers already sent by (output started at /home/content/n3pnexwpnas03_data03/72/41666972/html/wp-content/themes/quickstep/functions.php:724) in /home/content/n3pnexwpnas03_data03/72/41666972/html/wp-includes/pluggable.php on line 1216″ (not sure what has happened to cause this).

    I have spent ages on support chat with GoDaddy who suggested that it may be to do with the theme or the pluggin, again I am not sure how, it was working fine a couple of weeks ago. Are you able to advise at all or perhaps take a look if I provide you the information you require?

    Thank you so much, I am in India at the moment so finding it difficult to get support from them to easily.

    Regards

    Kat

    #47872

    Joshua
    Keymaster

    Ya, GoDaddy can be frustrating to deal with in terms of support. This error is coming from the theme, possibly due to the server setup. Can you try removing the very last line of the quickstep/functions.php file? It should look like this:

    ?>

    #47873

    Totally_Red18
    Participant

    Thanks Josh, Probably a stupid question on my part but how do i get to the PHP file? I can’t get onto the WordPress dashboard at the moment? (I get the same error message.)

    #47874

    Joshua
    Keymaster

    You should connect to your GoDaddy account via FTP (you can use a program like Filezilla if you don’t already have one). Alternatively, you can use the GoDaddy file manager.

    #47876

    Totally_Red18
    Participant

    Hi Josh,
    Went the Filezilla option and deleted the last line and re uploaded the file. I am still getting this Error message “Warning: Cannot modify header information – headers already sent by (output started at /home/content/n3pnexwpnas03_data03/72/41666972/html/wp-content/themes/quickstep/functions.php:724) in /home/content/n3pnexwpnas03_data03/72/41666972/html/wp-includes/pluggable.php on line 1216″

    What should I try next? and do I need to change the functions file back?

    Thanks

    Kat

    #47877

    Totally_Red18
    Participant
    This reply has been marked as private.
    #47879

    Joshua
    Keymaster

    Can you double check that the last line has been deleted entirely (no white spaces or line breaks)? The reason I ask is the error is still showing line 724, which is more lines than that file should have if the line was removed.

    You can also check to see that there are no spaces before the opening php tag:

    <?php

    If that doesn’t work I think you’ll need to check with your host (GoDaddy). Since this is not a known issue, it seems like there may be an issue with server configuration (possibly “ouptut_buffering”).

    #47880

    Totally_Red18
    Participant

    Josh,
    OMG getting so frustrated, they are now suggesting returning to default theme or the below:

    They can create a .user.ini file in sftp and write a code to enable output buffering to on
    output_buffering = on
    That’s the line which they need to give

    There must be some work around this?

    Kat

    #47881

    Joshua
    Keymaster

    Hi Kat,

    I’m not sure I understand the frustration. They offered to fix your server configuration- why not do that?

    Other than that, you can double check the modifications I posted in the last reply, but I think this may be directly related to your server configuration since no one else has encountered this issue.

    #47882

    Totally_Red18
    Participant

    Hi Josh, I think I am misunderstanding, they are offering to reset my site to the default team or telling me to request that you provide a user.ini file.

    Surely resetting my theme to default looses all the work I have done to date?

    Kat

    #47884

    Joshua
    Keymaster

    Resetting your theme does not resolve the issue; it’s just ignoring it.

    Most hosts will fix this for you since this is a hosting/server issue. GoDaddy is pretty far from a good host, but I’d be surprised they’d go as far as to not help you out with this.

    Sorry if this comes off the wrong way, but I’m not sure why we’d be providing a server configuration file for your host. Bottom line is that the hosting config needs to be fixed if you made the above changes and they did not work for you.

    #47886

    Totally_Red18
    Participant

    Hi Josh,
    No thats completely fine, I completely get it, I apologise I was getting frustrated, it was very much at them trying to offload it on to you.

    I ended up getting so frustrated that I got them to reset to a default theme, I then uninstalled and reinstalled Quickstep and deactivated any plugins I had added. I am pulling it back together now piece by piece and so far so good. However coming back to on my earlier issue about linking on page I am still having some difficulty. I have followed your instruction (1. If you want to link to somewhere on the homepage the URL should be your homepage url with the “slide” (not “slider”) attribute added to the end of the URL. For example: http://yourdomain.com?slide=contact) but it is still trying to create a new element at the bottom of the page rather than scrolling to the correct one. It works fine from top navigation but not from the page buttons (What I do, Get in Touch). Can you see what I am doing wrong?

    Thanks

    Kat

    #47887

    Joshua
    Keymaster

    No problem, Kat. I know how frustrating it can be sometimes.

    For page buttons you can just add in the slide attribute with the page you want to go to. For example, if your Contact page slug is ‘contact':

    [button slide="contact"] Slide to Contact Page [/button]

Viewing 15 posts - 1 through 15 (of 24 total)

You must be logged in to reply to this topic.