Home Forums Glissando Glissando Background angle wont work

Tagged: ,

This topic contains 14 replies, has 2 voices, and was last updated by  HornYkorN 4 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #46340

    HornYkorN
    Participant

    Hi, I know there are tons of posts about this issue, but nothing have helped me.
    I recently bought Glissando, and cant get the angled background to work. Background settings on my site
    The page itself

    #46341

    HornYkorN
    Participant
    #46342

    Joshua
    Keymaster

    Are you using the one-page-holder and have set the angles on each page? Could you post a link to your site please?

    #46346

    HornYkorN
    Participant

    Do the angles need to be set on all pages for it to work? And I am not sure what you are referring to by the “one-page-holder”. site: http://fagerstrandfilmogfoto.no/

    #46351

    Joshua
    Keymaster

    The one page holder is (available in the documentation) used for one-page sites. It’s required in order to use angles as they’re placed between pages.

    #46357

    HornYkorN
    Participant

    I didn’t know there were any documentation – that helped alot! :p
    Anyway, I’ve made it further with the instructions in the documentation. But do you know why I get this weird overlap? http://fagerstrandfilmogfoto.no/template/?slide=framside
    I also have some problems with the image on top, I cant decide which part of the image shows.

    #46361

    Joshua
    Keymaster

    It looks like there are different colors set for both of the top and bottom angles. You can actually just turn off those bottom angles and keep the top ones since in some cases (like that with the background image) just the one angle is needed to give the illusion of an angled page.

    As for the background image, you can set its position using the Background Position field beneath the editor when editing that page.

    #46369

    HornYkorN
    Participant

    Allright I got the angles working, thank you :)

    But I still have some issues with the placement of the background image. If you have a look at the main page now: http://fagerstrandfilmogfoto.no/, it varies how the background image look. On my desktop in full screen, it looks amazing. But If I scale down the image, or open it on another computer, it changes. Can I do something about that?

    Thanks for your assistance so far.

    #46371

    Joshua
    Keymaster

    So the problem is that the best looking part of that image is at the bottom, but a fixed or parallax-like background has to stretch it to the height of the screen (and the bottom part of the image is hidden behind your next section).

    First I would try changing your background position to ‘center bottom’ without the quotes.

    And then instead of using padding to give that section height, you could manually set it in your Custom CSS in theme options:

    #container-53 {
        height: 95vh;
    }

    Let me know if that looks any better.

    #46373

    HornYkorN
    Participant

    Thx for the quick reply.
    I’m guessing that code overwrites the padding top and padding bottom in the page layout settings? I would like the page to be smaller, so that the image don’t take up the entire screen. However, when I change these page settings, nothing happens. And if I change the container height in css, it just clips from the bottom right, but then it cuts away the nice part of the image.

    Since I’ve allready started bothering you, I’ll add a question about portfolio: As you can probably see, I’ve tried adding my portfolio on the page. It seems like there might be something wrong with the links? And I can’t get the images to show?

    #46374

    Joshua
    Keymaster

    What you’re trying to do with the background is impossible if you think about it. A fixed or parallax background requires the image to be the height of the screen to provide this effect. If your container area has less height than the height of the screen, the bottom will be clipped and that’s the piece of the image you’re trying to show. You can either make the container roughly the height of the screen or remove the parallax background effect.

    I believe the portfolio images not showing is related to the retina plugin you have activated. Try disabling that and let me know if it solves the issue.

    #46376

    HornYkorN
    Participant

    Allright I understand, thanks.
    I think the reason we didn’t see the images, was that I had not enabled a featured image on the side. I did, and got it working. However, it raises a second question: Can I ONLY have the featured image on the porfolio page, and not in the post itself? To me it seems unnecessary to have the featured image on the post itself, and the video below. I would like to have the video sit alone on the page. How can I achieve that?

    #46377

    HornYkorN
    Participant

    And I am sure this is really easy, and I am just being weird not finding it…but where is the option to change the hover color of the featured images in the portfolio?

    #46379

    Joshua
    Keymaster

    The portfolio hover color should be set by your theme’s accent color, but in case that’s not working you can set in your Custom CSS with the following:

    .portfolio-container .isotope .portfolio-overlay {
        background-color: rgba(186, 171, 139, 0.9);
    }

    You’ll need to use an RGBA color to give some level of transparency.

    You can disable the featured image on a portfolio page by adding this to your Custom CSS:

    .single-portfolio .featured-content {
        display: none;
    }

    If you need this specific to a portfolio page, you can use the ID of the post:

    .single-portfolio.postid-95 .featured-content {
        display: none;
    }
    #46380

    HornYkorN
    Participant

    There we go, thank you so much! :)

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.