Home Forums Fusion Getting a Parse error upon install

This topic contains 5 replies, has 4 voices, and was last updated by  Joshua 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #46625

    meadowsfca
    Participant

    Getting a Parse error upon install. 5.6+ php installed

    Parse error: syntax error, unexpected ‘[‘ in /themes/fusion/inc/helpers.php on line 134

    line 134 $categories = [];

    #46626

    Joshua
    Keymaster

    Sorry about that- we did not run into bug when testing 5.6 and I’m testing on a 5.6 environment and can’t seem to reproduce this error.

    That error sounds like one from an older version of PHP (<5.4). Could you double check and make sure you're on 5.6?

    One other thing we can try is changing that line in helpers.php to this:

    $categories = array();

    If that resolves it, there may be a hidden character causing a bug, but if you get another error, it’s probably indicative of an issue with the PHP library.

    #46627

    Joshua
    Keymaster

    If you’re still having trouble, feel free to privately post back here with your login credentials and cPanel credentials and I’ll be glad to take a look for you first thing in the morning.

    #46844

    Peethe
    Participant

    Hi there, I’m getting the same issue.
    I tried changing line 134 as suggested but now I get the same problem in /wp-content/themes/fusion/inc/elementor.php on line 24.
    Any help would be appreciated,
    Cheers,
    Dale

    #46846

    inkarnating
    Participant

    I got the same error … reinstalled the theme manually and it got uploaded … but theme documentation is very poor

    #46849

    Joshua
    Keymaster

    Hi @Peethe – We never got a response back from the original poster, but I believe the issue was that the PHP version was not in fact 5.6 or greater. Please confirm that you have 5.6+ or feel free to post back if you still have the issue and are running a version greater than 5.6.

    @inkamating – Sorry if you ran into trouble here, however if you were able to install successfully on manual upload, this implies a corrupt file and potentially an issue with your WordPress install. There’s not much we can do to help there as it’s not a theme issue. I’m also curious which part of the theme documentation you feel is poor.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.