Home Forums Etch ETCH: CSS links in header are not updating for HTTPS

This topic contains 3 replies, has 2 voices, and was last updated by  Joshua 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #47566

    eadcock
    Participant

    Hello Joshua,

    Long time! We’ve recently switched our hosting to HTTPS and the CSS links in the header are not always updating to HTTPS (links to http://), which is breaking the style links and causing some issues with the site (in firefox and chrome igcognito mode). Weird thing is, the css links will only break on some of the pages, some of the time. It seems to hit the pages with post summaries the worst at times when I’m in the site backend, but other than that I cannot see a pattern. The site is https://cloud4good.com and the pages that are being effected the most by this are:

    https://cloud4good.com/blog/

    https://cloud4good.com/success-stories/

    https://cloud4good.com/contact-us/

    https://cloud4good.com/about/best-job-ever/

    Is there a way that I can force the site to only go to HTTPS urls in the style links in the header?

    #47567

    Joshua
    Keymaster

    Not sure if you got this resolved already or not, but I’m seeing the links for the main stylesheet as https for all those pages.

    If you’re still seeing them the other way on those or only some pages, chances are you’re seeing a cached version of the page.

    #47569

    eadcock
    Participant

    Hello Joshua,

    Thank you for getting back to me! Just found that it was an issue with a global rewrite in the htaccess file. I fixed the issue and site seems to be running stable.
    On another note, the latest wordpress update caused an issue with the header image overlay rgba_colorpicker in the metaboxes.php file in the frameworks folder. It was making the color picker toggle on and off anywhere the header image section was clicked on, which disabled changing any of the other elements aside from the overlay color. We don’t use it anyway so I disabled it, but I thought I’d mention it.

    #47571

    Joshua
    Keymaster

    Thanks for reporting back.

    I believe that issue was solved by an update a few weeks ago to the color picker, but turning it off is okay too.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.