Home Forums SimpleFlex Animations and autoscroll stopped working on Crhome

This topic contains 16 replies, has 6 voices, and was last updated by  Joshua 1 month ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #46983

    gianzelada
    Participant

    All animations and the auto scroll effect on the Single Page menu stopped working on Crhome.

    I tested the sites I developed and the Simple Flex site itself (http://preview.themeforest.net/item/simpleflex-flat-one-page-wordpress-theme/full_screen_preview/7247149) and the error persists.

    Is there an update that fixes this error?

    Thanks!

    #46986

    Joshua
    Keymaster

    Hi gianzelada,

    This is an issue with the latest version of Chrome. There is a quick fix for it and requires the following 2 steps:

    1. In your themes folder js/jquery.scrollTo-1.4.3.1-min.js entirely replace the content with this – https://raw.githubusercontent.com/flesler/jquery.scrollTo/master/jquery.scrollTo.js

    2. In your theme’s folder includes/admin/luxe-options.php you’ll need to find and replace every occurence of:

    jQuery.scrollTo.window().queue([]).stop();

    With this:

    jQuery(window).clearQueue();

    That should be all that’s needed to get it working. Let me know if you have any trouble with this.

    #47005

    gianzelada
    Participant

    Hello Joshua,

    It worked correctly, thank you!

    Gian

    #47078

    Kitazawa
    Participant

    I also have the same problem.
    The auto scroll effect on the Single Page menu stopped working on Chrome.
    I am using “quick step”.
    I would be happy if you could tell me how to repair my home page.

    1)There are “jquery.scrollTo-1.4.2-min.js” in my theme’s folder js.
    2)There are not “luxe-options.php” in my theme’s folder includes/admin.

    Thanks!

    #47082

    Joshua
    Keymaster

    Hi @Kitazawa

    Replied to you in your other thread. You can post back there if you have any more questions – http://themeluxe.com/support/topic/the-auto-scroll-effect-on-the-single-page-menu-stopped-working-on-chrome/

    #47102

    macamrstudios
    Participant

    Hi – I too have been having problems with Chrome. I implemented your updates as mentioned above, and while the scrolling now works, the content within these pages is not. Is there an additional file that needs updated?

    All works as it should on Safari (Version 11.0 (12604.1.38.1.7)) but not Chrome (Version 61.0.3163.100 (Official Build) (64-bit))

    Here is a production version of the site in question (note, same issues are happening on the live site, but for debugging, I set up a mirror copy on a production server).

    http://www.macamrstudios.com/production/ph18/

    Thanks in advance for your assistance.

    #47105

    Joshua
    Keymaster

    Hey @macamrstudios

    There’s one more fix in Chrome 61 for the animations to fire correctly. Here it is – http://themeluxe.com/support/topic/error-happened-in-home-page/#post-46999

    #47118

    macamrstudios
    Participant

    That seems to have fixed everything. Thank you!

    #47646

    ekuk
    Participant

    Hi, having the same issue with your theme (Max) at http://www.wales-holiday.com. Thought I’d broken it until I discovered that your demo site doesn’t work in chrome either ie http://max.themeluxe.com/ in exactly the same way ie The menu wasn’t working and some of the content was invisible ie any content using [animate] eg [animate style="fadeInLeft" delay="1000"][metaslider id=2217][/animate]

    I’m on the latest version of the theme and wordpress etc is up to date, I’ve removed all other plugins just to avoid confusion. I then tried the fix mentioned in the thread swapping out the js file code and editing the lux-options using find and replace, after which the menu works however we still have content not showing in chrome. Do you have a fix for the animate issue?

    #47648

    Joshua
    Keymaster
    #47650

    ekuk
    Participant

    I’ve done the following, which fixed the menu but not the animation

    1. In your themes folder js/jquery.scrollTo-1.4.3.1-min.js entirely replace the content with this – https://raw.githubusercontent.com/flesler/jquery.scrollTo/master/jquery.scrollTo.js

    2. In your theme’s folder includes/admin/luxe-options.php you’ll need to find and replace every occurence of:

    jQuery.scrollTo.window().queue([]).stop();

    With this:

    jQuery(window).clearQueue();

    Is this the change you mean? Or is there something else I’ve missed

    #47651

    Joshua
    Keymaster

    No, that’s not the one. If you click the link I just posted, you’ll see the relevant post on fixing animations.

    #47930

    jouls
    Participant

    Hi,
    mi site is http://www.lexor.it
    using chrome i cannot get the page to scroll and even if I manually scroll down the page my animation doesn’t appear.
    I’ve updated ad you explained here:
    This is an issue with the latest version of Chrome. There is a quick fix for it and requires the following 2 steps:
    1. In your themes folder js/jquery.scrollTo-1.4.3.1-min.js entirely replace the content with this – https://raw.githubusercontent.com/flesler/jquery.scrollTo/master/jquery.scrollTo.js
    2. In your theme’s folder includes/admin/luxe-options.php you’ll need to find and replace every occurence of:
    jQuery.scrollTo.window().queue([]).stop();
    With this:
    jQuery(window).clearQueue();

    I also did the update on animation bus as you explained here:
    In your theme’s js/scripts.js file, can you try searching for this line:
    var scrollElem = ((navigator.userAgent.toLowerCase().indexOf(‘webkit’) != -1) ? ‘body’ : ‘html’);
    And replacing with this:
    var scrollElem = $(document.scrollingElement || “html”);
    Please let me know if that works for you and if not we’ll work on something else.

    Nothing is changed, could you help?
    Scrolling an animations are working on microsoft edge

    #47931

    jouls
    Participant

    Sorry,
    af far as the animations, after your fix they appear to be working if I manually scroll down.
    The menu scroll still doesn’t work

    #47932

    Joshua
    Keymaster

    The problem is that this line was pasted into your scrollTo file:

    https://raw.githubusercontent.com/flesler/jquery.scrollTo/master/jquery.scrollTo.js

    You need to visit that URL and paste the contents of that page into your scrollTo file.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.